Extension ID:
Release date:
11/05/2017 - 17:08
Operating system:
System Independent
3.0, 3.0.1, 3.1, 3.2, 3.3, 3.4, 4.0, 4.1
Binary type:
OpenOffice extension (.oxt)
Release Notes: 

Changes to OOoLilyPond 0.5.5 since 0.5.4:

* speed up language file loading on macro startup
* highlight LY compiler error messages in editor window

Changes to OOoLilyPond 0.5.4 since 0.5.3:

* [SVG] templates are prepared to support the new texgyre*.otf fonts

There have also been some minor changes to the language files from 0.5.1 to 0.5.2. So, when updating from a version prior to 0.5.2, please launch OLy, open the config dialog and click the "Restore Language Files" button.
(Your current language files will be backed up in a subfolder. If you like, you can delete that subfolder.

Changes to OOoLilyPond 0.5.3 since 0.5.2:

* for Windows users: better estimate for program files folder on 64bit systems
* backup folder names more readable
* some minor corrections

Changes to OOoLilyPond 0.5.2 since 0.5.1:

* fixed: runtime error if path for language files could not be found
* new: path for language files can be specified in config dialog
* for Linux users: new location for temporary files (now being .cache/ooolilypond/tmp instead of .ooolilypond-tmp - you can delete the latter if you want to get rid of it).

Changes to OOoLilyPond 0.5.1 since 0.5.0:

* fixed: missing parentheses in source code caused runtime error in LibO
(Apparently, LibreOffice has a more strict syntax checking whereas earlier versions silently ignored that.)

Changes to OOoLilyPond 0.5.0 since 0.4.0/0.4.1:

* fixed: Runtime error Variable not defined: line 40 CurserPosition=1
* additional include paths can be specified
* added button to save the current code into temporary file and open it in external editor
* added button to re-import code from temporary file back to editor window
* added support for the use of SVG graphics format
* fixed: wrong size of vector graphics in Impress/Draw
* size and crop settings of existing graphics can be preserved
* user now can choose between two different ways to import graphic into document
* font name and font size for editor windows can be specified
* user interface can be translated into other languages


OOoLilyPond (OLy) works with recent versions of LibreOffice ( and OpenOffice (4.1.3). Older versions should work as well. It has even been tested with OpenOffice 2.4 without issues.

Any content (LilyPond code, templates, OLy configuration files) created with/for OLy 0.4.x will work with OLy 0.5.x - and vice versa. (Fully compatible, forward and backward.)
Older snippets created with OLy 0.3.x will also work with 0.4.x and 0.5.x, but not (necessarily) vice versa.

This new take on the OOoLilyPond project is hosted at: